No customization options are available.

Charging and the running light comes on?

Discussion in 'Servicing & Maintenance' started by GrahamleM, Oct 2, 2017.

  1. GrahamleM

    GrahamleM Member

    Messages:
    39
    Likes Received:
    22
    Trophy Points:
    8
    Hope someone can shed some light on a problem. Playing about with my new BMW CAN bus battery charger, when I switch on the charger, it goes through its warming up process and proceeds to charge as it should but all of a sudden the R1200RS sports running light comes on by its self. It may go out by itself but comes back on. When the battery says 100% charged, the little bugger is either on or comes on and the charger wont go into sleep mode (probably because the running light is drawing a small current?) I have tried switching the running light off in the setup menu, having the key in the ignition, out of the ignition. Sure there is a gremlin in my garage :eek:. Can someone help?
     
  2. Andy Griffiths

    Andy Griffiths Well-Known Member

    Messages:
    1,772
    Likes Received:
    1,449
    Trophy Points:
    113
    Character :)
     
  3. GrahamleM

    GrahamleM Member

    Messages:
    39
    Likes Received:
    22
    Trophy Points:
    8
    Ha ha, just want my expensive bits to work Andy. Don't want to take a broken branch to it just yet!
     
    Leon.P. likes this.
  4. boxter

    boxter Active Member

    Messages:
    489
    Likes Received:
    246
    Trophy Points:
    43
    I'm assuming you connected your charger to the accessory socket, I connected mine direct to battery, it may have been a wise move from what you say, the reason I'm asking is other members have mentioned issues using accessory socket.
    If it's a optimate 4 ( in a different disguise) you have to set up the machine at start up for can bus.

    OR it may just be a clever signal system :)

    Ged
     
  5. Richard230

    Richard230 Well-Known Member Contributor

    Messages:
    2,689
    Likes Received:
    1,973
    Trophy Points:
    113
    I use the BMW charger hooked up to the accessory socket every time I return from a ride. I have never had that problem - but then my bike doesn't have a running light. One thing I do is to first connect the charger to the socket and then power up the charger from the wall electrical outlet. If you keep having this problem, perhaps you have a defective charger and you should return it to your dealer for a refund or replacement.
     
  6. GrahamleM

    GrahamleM Member

    Messages:
    39
    Likes Received:
    22
    Trophy Points:
    8
    I do use the accessory socket Ged. You say that you have to set up the machine for can bus?
    Cheers
     
  7. GrahamleM

    GrahamleM Member

    Messages:
    39
    Likes Received:
    22
    Trophy Points:
    8
    Thanks Richard, I have tried all variables. i am wondering if it is a setting on the bike?
     
  8. boxter

    boxter Active Member

    Messages:
    489
    Likes Received:
    246
    Trophy Points:
    43
    Make sure it's an optimate 4 you have, if so you turn charger on and short the connectors, this switches back and forth between standard charging and can bus charging,

    Warning!!! If it's not an optimate 4, do NOT short the leads.

    Check optimate 4 on net, see if yours looks the same.

    Ged
     
  9. boxter

    boxter Active Member

    Messages:
    489
    Likes Received:
    246
    Trophy Points:
    43
    Like this
     

    Attached Files:

  10. GrahamleM

    GrahamleM Member

    Messages:
    39
    Likes Received:
    22
    Trophy Points:
    8
    Hello Ged it looks like this and comes with the can bus plug. The literature says that it is can bus.
     

    Attached Files:

  11. Yoda

    Yoda Active Member

    Messages:
    380
    Likes Received:
    171
    Trophy Points:
    43
    Does the rear light come on with the DRL?
     
  12. SauRoN

    SauRoN Well-Known Member

    Messages:
    1,001
    Likes Received:
    418
    Trophy Points:
    83
    Maybe it's becoming self aware from the extra power and is trying to send you messages. :)
     
    Bravo, Scorch and GrahamleM like this.
  13. GrahamleM

    GrahamleM Member

    Messages:
    39
    Likes Received:
    22
    Trophy Points:
    8
    No Yoda, the rear light stays off. I can get the running light to go out if I turn the ignition on the off but this fix is short lived as it pops back on shortly afterwards. I note that its brightness when it comes on by itself is not as bright as when you turn the ignition on.
     
  14. runnerhiker

    runnerhiker Well-Known Member Contributor

    Messages:
    680
    Likes Received:
    427
    Trophy Points:
    63
    It looks like others here are not experiencing this, it's time to go back to the dealer.
     
    GrahamleM likes this.
  15. Martien

    Martien Member

    Messages:
    66
    Likes Received:
    52
    Trophy Points:
    18
    Hi Graham, I noticed exactly the same issue you described, front DRL on but no tail light on, when connecting the Optimate 4 to my RS today. Last winter I used it for my F700GS, which also had can-bus and was charged via the power socket, so the Optimate is configured correctly...

    Did you replace your Optimate or get an answer to your queries at the dealer?
     
  16. GrahamleM

    GrahamleM Member

    Messages:
    39
    Likes Received:
    22
    Trophy Points:
    8
    Hello Martien. My bike goes in for its first service soon. I will tell the technicians about this problem then. I don't have the Optimate 4 but the BMW charger which says that it works with canbus. It is in a way nice that someone else has seen this problem as you are the first to reply to this issue. I will report back their response.
     
    Martien likes this.
  17. GrahamleM

    GrahamleM Member

    Messages:
    39
    Likes Received:
    22
    Trophy Points:
    8
    Bike goes in for its first service on 9th November and I have reported it over the phone. Will keep you informed.
     
    Martien likes this.
  18. GrahamleM

    GrahamleM Member

    Messages:
    39
    Likes Received:
    22
    Trophy Points:
    8
    Well the technician is stumped. Took the charger in to demonstrate the problem. he sent off a "ticket" to BMW. Have not heard back yet!
     
  19. Martien

    Martien Member

    Messages:
    66
    Likes Received:
    52
    Trophy Points:
    18
    Talked to a BMW technician yesterday and he also suspected a defective charger. Will take the RS and Optimate to the dealer next year for a test. Now for this winter I changed the program to regular (non Canbus) charging, and connected directly to the battery, so far it seems to be charging normally.
     

Share This Page